Matthew Robb (2012-08-27T02:55:56.000Z)
I agree with Rick on the general feeling with Array.of

If arguing ambiguity I would argue a better method name for type guarded
arrays would be Array.ofType


On Sun, Aug 26, 2012 at 8:56 PM, Rick Waldron <waldron.rick at gmail.com>wrote:

>
> On Sunday, August 26, 2012 at 7:30 PM, Brendan Eich wrote:
>
> Rick Waldron wrote:
>
> But Array.of is not. Maybe Array.new is a good name.
>
> Array.of is unambiguous with the current ES specification
>
>
> Array.new is ok too, though -- no problem with a reserved identifier as
> a property name. It's darn nice for Rubyists.
>
> OTOH Array.of matches the preposition pattern used in Array.from. But I
> don't think this trumps Array.new.
>
>
> Nor do I, but I think it poses a problem for polyfilling (which is not a
> silver bullet).
>
> +1 Array.new, but I still think Array.of sounds, feels and looks nicer
>
> Rick
>
> Cc'ing Dave for his thoughts.
>
> /be
>
>
>
> _______________________________________________
> es-discuss mailing list
> es-discuss at mozilla.org
> https://mail.mozilla.org/listinfo/es-discuss
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20120826/d72bb200/attachment.html>
domenic at domenicdenicola.com (2014-01-03T16:27:32.298Z)
I agree with Rick on the general feeling with `Array.of`

If arguing ambiguity I would argue a better method name for type guarded
arrays would be `Array.ofType`