Axel Rauschmayer (2013-08-29T07:13:21.000Z)
> [...] I think this makes a good case for a lazy execAll -- with a much better name.
> 
> Candidates: r.iterate(s), r.iterateOver(s), r.execIterator(s) (blech!). Suggest some!


I think “exec” should be in the name, to indicate that the new method is a version of `exec()`.

Ideas:

– execMulti()
– execIter()

`execAll()` may not be that bad. It’s not pretty, but it’s fairly easy to guess what it does (*if* one know what the normal `exec()` does).

-- 
Dr. Axel Rauschmayer
axel at rauschma.de

home: rauschma.de
twitter: twitter.com/rauschma
blog: 2ality.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20130829/508c3774/attachment-0001.html>
domenic at domenicdenicola.com (2013-09-08T00:20:16.401Z)
> [...] I think this makes a good case for a lazy execAll -- with a much better name.
> 
> Candidates: r.iterate(s), r.iterateOver(s), r.execIterator(s) (blech!). Suggest some!


I think “exec” should be in the name, to indicate that the new method is a version of `exec()`.

Ideas:

* execMulti()
* execIter()

`execAll()` may not be that bad. It’s not pretty, but it’s fairly easy to guess what it does (*if* one know what the normal `exec()` does).