Claude Pache (2013-12-18T22:06:51.000Z)
domenic at domenicdenicola.com (2014-01-03T16:52:37.881Z)
> Well, even it's confusing it's still better than `of` for the use case, and some other alternatives: > > ```js > Array.fromItems // fromXXX has another benifit that alternative constructors (String.fromCharCode, Array.from) all begin with `from` > Array.fromList > Array.fromArguments > Array.newArray > Array.makeArray > Array.theFixedConstructorWithoutGotchas > ``` > > I like the last one ;) what about you? Of/from the alternatives proposed, I find `Array.fromArguments` compelling, because it is self-descriptive once you know what does `Array.from`: Array.fromArguments = function() { return Array.from(arguments) } Remarkably, `Array.fromElements` sounds particularly bad to my ears, because it seems to be a synonym of `Array.from` when applied to an array. ("Array from [the] elements [of] ...") Personally, I'd not thought that `Array.of` would be a problem, but apparently, since even people that are fine with that name tend to mingle it with `Array.from`...