Allen Wirfs-Brock (2014-08-22T16:23:27.000Z)
On Aug 22, 2014, at 7:22 AM, Kevin Smith wrote:

> 
> 
> Also, write your echo generator this way. You have to duplicate code.
> 
> 
> Ah, of course - thanks for reminding me. 
> 
> 
> Given something like:
> 
>     function *echo() input { while (true) yield input }
> 
> It seems like what we're trying to do is to emulate a contextual keyword using a weird "outside of the parameter list" parameter.  I suppose one ideal future-proof way forward would be to reserve an additional word inside of generators for this potential use in ES7+. 
> 
> Of course, everyone would have to agree on what that reserved word should be...
> 

and it could only be reserved in strict mode code.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20140822/0b874469/attachment-0001.html>
domenic at domenicdenicola.com (2014-08-26T18:26:47.741Z)
On Aug 22, 2014, at 7:22 AM, Kevin Smith wrote:

> Of course, everyone would have to agree on what that reserved word should be...


and it could only be reserved in strict mode code.