Gary Guo (2015-02-13T03:55:35.000Z)
Actually I disagree with you. `Class` will not be confusing, since as you said, people probably will use `toStringTag` once per `class`. So `classTag` just becomes a better name. String, Boolean, etc, are just names of classes.

From: ljharb at gmail.com
Date: Mon, 9 Feb 2015 09:55:01 -0800
Subject: Re: Property names for public symbols
To: nbdd0121 at hotmail.com
CC: brendan at mozilla.org; es-discuss at mozilla.org

"[[Class]]" was the pre-ES6 term to refer to this value, but with the ES6 "class" keyword that would be confusing, and I don't think it would be a good idea to conflate the meaning of the term even further.  "toString" is a common single idiom in JS since it's the function that String() invokes, so "toStringTag" works for me.
This particular value is one that, imo, in practice should be rarely used (once per "class" perhaps, in its definition), so I'm not hugely concerned about the naming (my concerns were about the behavior). My guess would be that in order to effect a change at this very late date, one would have to propose a name that was so compelling as to make it an obvious choice.
On Mon, Feb 9, 2015 at 7:16 AM, Gary Guo <nbdd0121 at hotmail.com> wrote:



How about "classTag" instead of "toStringTag", which makes it sound like a noun.
 		 	   		  



 		 	   		  
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20150213/90088638/attachment.html>
d at domenic.me (2015-02-17T20:22:05.787Z)
Actually I disagree with you. `Class` will not be confusing, since as you said, people probably will use `toStringTag` once per `class`. So `classTag` just becomes a better name. String, Boolean, etc, are just names of classes.