Xavier Stouder (2017-07-04T15:37:07.000Z)
Even if I think it should be a performance improvement, the main goal
actually is to improve readability and conciseness of the code.

 

When you say "I'd expect it to be something closer to [min, max] =
Math.minMax(foo, bar)", are you saying that minmax (or minMax) should only
take two arguments ? I think that if it's implemented like this, it would
obviously be not so usefull.

 

Some questions about the proposal process :

-          Are champions reading and commenting this feed ? Can we have a
comment on this proposal maybe ?

-          Is the purpose of proposals to question how the proposal would be
implemented by JS engines ?

-          Talking about tests previously quoted : Is an JS implementation
of this proposal just approaching how efficient (or not) would be the
proposal after being implemented by JS engines ?

 

Thanks for your feedback.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.mozilla.org/pipermail/es-discuss/attachments/20170704/32924126/attachment.html>
xavier+github at stouder.io (2017-07-04T15:42:55.436Z)
Even if I think it should be a performance improvement, the main goal
actually is to improve readability and conciseness of the code.

 

When you say "I'd expect it to be something closer to [min, max] =
Math.minMax(foo, bar)", are you saying that minmax (or minMax) should only
take two arguments ? I think that if it's implemented like this, it would
obviously be not so usefull.

 

Some questions about the proposal process :
- Are champions reading and commenting this feed ? Can we have a
comment on this proposal maybe ?

- Is the purpose of proposals to question how the proposal would be
implemented by JS engines ?

- Talking about tests previously quoted : Is an JS implementation
of this proposal just approaching how efficient (or not) would be the
proposal after being implemented by JS engines ?

 

Thanks for your feedback.