Math.roundUp(), an alias for Math.ceil()

# Eric Andrew Lewis (6 months ago)

this is my first message to the list. Thanks for all that you do to improve the programming language for the web!

This is probably a curious proposal that will go nowhere but I thought it'd be interesting to share a suggestion and see how it goes.

I teach introductory JavaScript. Students have a hard time remembering the method name Math.ceil(). It looks like the name "ceil" dates back to at least the C programming language, and probably earlier.

I suggest introducing Math.roundUp() as an alias for Math.ceil() to provide an easier to read and remember method name. If this makes sense, introducing Math.roundDown() might be a good alias for Math.floor() as well.

I searched for previous discussions on creating method name aliases and couldn't find one to see how the committee has made decisions about them in the past.


# Rob Ede (6 months ago)

From my experience, folks don’t like adding things to the spec that are very easily implemented (like aliases) in userland. All you’d need is a Math.roundUp = Math.ceil to start using the code you want.

, Rob

# Sebastian Malton (6 months ago)

An HTML attachment was scrubbed... URL: esdiscuss/attachments/20180804/d075c9d2/attachment